Creality Ender 3 X axis homing issue

  • I bought an Ender 3 recently. Auto-home is on the right front moving away from the end stop. I did reverse the wiring of the X axis motor, it did not work. I had Marlin 2.x uploaded, it didn't work too.



    Marlin 2.x:





    The print starts off with a boundary line in the middle and goes off the bed on the right corner to print. Y and Z axes are fine. X axis seems to be bumping into the right front, every time while homing. I had tweaked little bit of Marlin, but I'm a beginner and I don't understand it completely.



    I'm using Cura, printer settings, max X=235, max Y=235, max Z=250, origin at the center: unchecked.



    This might help...



    // The size of the print bed
    #define X_BED_SIZE 235
    #define Y_BED_SIZE 235


    #define X_MIN_POS 0
    #define Y_MIN_POS 0
    #define Z_MIN_POS 0
    #define X_MAX_POS X_BED_SIZE
    #define Y_MAX_POS Y_BED_SIZE
    #define Z_MAX_POS 250


    #define MANUAL_X_HOME_POS 0
    #define MANUAL_Y_HOME_POS 0
    #define MANUAL_Z_HOME_POS 0


    (left this after so many trails)



    In Pronterface the mid point X117.5 is at the middle right corner.



    I'm thinking the printer is behaving like the origin(0,0) is on the right front, for X at least and it has nothing to do with the slicer.



    It's about centering the prints, but it doesn't print on the bed mostly.






    Start G-code:



    ; Ender 3 Custom Start G-code G92 E0 
    ; Reset Extruder G28
    ; Home all axes G1 Z2.0 F3000
    ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
    G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
    G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
    G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
    G92 E0 ; Reset Extruder
    G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
    G1 X5 Y20 Z0.3 F5000.0 ; Move over to prevent blob squish


    End G-code:



    G91 ;Relative positioning 
    G1 E-2 F2700 ;Retract a bit
    G1 E-2 Z0.2 F2400 ;Retract and raise Z
    G1 X5 Y5 F3000 ;Wipe out
    G1 Z10 ;Raise Z more
    G90 ;Absolute positionning
    G1 X0 Y{machine_depth} ;Present print
    M106 S0 ;Turn-off fan
    M104 S0 ;Turn-off hotend
    M140 S0 ;Turn-off bed
    M84 X Y E ;Disable all steppers but Z

    Hi welcome to 3DPrinting.SE!

  • 0scar

    0scar Correct answer

    2 years ago

    The issues you are facing can be caused typically by a defective X-axis endstop, an inverted logic of the X-axis endstop or a defective printer controller board.



    When the X-axis endstop is reporting being triggered, it will not move. After "homing" it will only go to the right of the "home position".



    There a couple of things to troubleshoot the X-axis endstop working:




    • Command an M119 command over a printer console or connect your printer over USB to a printer software application like PronterFace, OctoPrint, Repetier-Host, etc. and look at the reported endstop triggers; these should be triggered when the endstops are pressed. Issue the M119 when you press the X endstop manually, if it reports "open" for X you need to invert the logic. If still triggered, the endstop is broken.

    • Swap the X-endstop for a any other endstop (Y or Z); then you can also check if the printer board is broken!






    If it is the case to invert the polarity of the endstop, in the Marlin firmware Configuration.h, look up:



    // Mechanical endstop with COM to ground and NC to Signal uses "false" here (most common setup).
    #define X_MIN_ENDSTOP_INVERTING false // set to true to invert the logic of the endstop.


    Change the boolean value of the endstop you'd like to invert.


    You are right, the limit switch top is missing, can you tell me the revert instructions and then I will check for the board. I will and keep you posted, since it is very irritating to disassemble, i will take some time to update. Thank you, once again.

    Oscar, I have a question, top one of the switch(one that makes 'click' sound) is missing, nothing of an electric component, I guess. Still x-axis should end up on it, right?

    The click is the sound the switch makes internally, maybe you could add an image of the switch to the question? I do not fully understand what you mean by `the limit switch top is missing`. Is the metal lever missing? See this question.

    Yes, the metal lever(phew!) is missing. Does the machine know that, even before moving along the x-axis>

    The lever presses the small micro-switch, if it is missing, the switch will not be pressed (as it relies on the lever), but that is not an issue as your printer does not home on X the switch is broken and should be replaced. Just buy a new one, literally a few cents at th electrical electronics components store or any online alternative!

    Yes, would replacing be enough or do I have to invert the endstop polarity too?

    Why I'm saying this, because, it's COVID-19 lock down in India till 14th of this month and it is said that it will extend till end of may or june, except for groceries and essentials, there will be no other online or local store for 'limit switch'. And my doubt is if the hardware component is missing does the motherboard and code know that beforehand? And can I use the end switch that is in the DVD player:-)

    it's a silly question maybe.

License under CC-BY-SA with attribution


Content dated before 7/24/2021 11:53 AM