Simple Products not showing as associated in configurable products

  • I need to ask about how to set up a simple product to be able to show it to my configurable associated products.

    I think I already configure all the attributes like,

    1. visibilty = not show inidividually
    2. stock = in stock
    3. attribute set = the same as configurable product
    4. price = also set
    5. status = enable

    anything I missed? Because when go to my configurable product some of my simple products created wouldn't show up as Associated Products.

    How did you create the simple products? Make sure that they are associated to the configurable product. Go into the configurable product, select the 'Associated Products' tab and see if all simple products are associated correctly.

    My simple products are the same attribute set as configurable product. But one my simple products is not showing up in associated tab. I cant find the simple products in there. What do you think happen?

    I had a similar problem and for some reason I could only get around it by making the first associated product with the "Create Simple Associated Product" detailed form, rather than the "Quick simple product creation" section. After that, quick creates worked.

    @YvesGonzaga @ Your configurable attributes needed to be set to Apply To "All Product Types", not just configurable. haven't tried but maybe even just selecting "Configurable and Simple" products.

  • Simon

    Simon Correct answer

    6 years ago

    Make sure that you associated the simple products with the configurable product. Therefore, go to the configurable product, open the "Associated Products" tab, select the appropriate simple products and save. If you do not see your simple products there, make sure to click on "Reset Filter" (and that your simple products have the same attribute set as your configurable one). As always, you may need to reindex or clear your cache.

    That is my problem. In my associated tab I cant find the simple products in there. What do you think happen?

    @YvesGonzaga see my edited answer above.

    LOL your right that "reset filter button" in there. I haven't use it because I thought when I reload the page the associated products will reload too. I think there's some special function on that "reset filter" button. Thank you so much.

    Even with the filter reset (and the left one set to "any") I can only see products that are already associated with it.

    @Mike Your configurable attributes needed to be set to Apply To "All Product Types", not just configurable. haven't tried but maybe even just selecting "Configurable and Simple" products.

License under CC-BY-SA with attribution


Content dated before 7/24/2021 11:53 AM