Field Not Showing in Process Builder

  • I wanted to add an "Update Records" action in a process and set a new checkbox field to true which I created just before. However, even after reloading process builder the field is not available in the list of fields to update... is the list cached somewhere or am I missing something obvious?

    @JohnnyStenson I won't remove that commet as it could be of use to someone, but the actual answer was Shannon's which I accepted nearly 5 years ago! I just got confused by the UI at the time.

  • shannonsans

    shannonsans Correct answer

    6 years ago

    I tried this and saw my checkbox field no problem, so I'm going to hazard a guess that you have fallen into the "Select a Field" overlay trap. Which is this:

    When you click on the "Object" field and it gives you the "Select a Field" overlay, it's REALLY asking you to select an object, not a field. So it gives you a list of lookup fields to navigate to a related object.

    If you click on the object name, and click save, it will then give you a list of fields on that object that you can update.

    enter image description here

    enter image description here

    enter image description here

    Wow, that is exactly what I did. Time to go pester the UI team methinks ;)

    They are already aware of it. I did exactly the same thing a couple weeks ago, and I only have to walk 3 aisles over ;-)

    Could you go pester them again please - I just wasted 5 minutes of my life on the same issue :-)

    This helped me when I got stuck in Lightning super badge. It was actually confusing in Process builder. Thanks.

License under CC-BY-SA with attribution


Content dated before 7/24/2021 11:53 AM