Developer Console is not loading

  • When I login to Salesforce and open Developer Console, Window pops up but Says "Loading...". My Salesforce instance is na24. I am able to open Developer Console of my other Developer Edition in the browser. Same behavior is observed in Chrome, Firefox and Internet Explorer.

    My other Developer edition instance is also na24

    Did you try clearing your cache? I also have one on na24 and the developer console is working.

    are you a sys admin (or) have View All Data?

    Yes I have cleared cache.It doesn't help. Also I am sys admin and has View All Data permission.

  • Suneel

    Suneel Correct answer

    6 years ago

    Below are the steps for resolution Salesforce provided
    1. login and open Developer Console by Chrome
    2. open Developer tools and select Network
    3. reload on Developer Console
    Use the following query to get the IDEWorkspace

    /services/data/v31.0/tooling/query/?q=SELECT id, name from IDEWorkspace

    and you would get Id: 1de1a0000014sEWAAY
    IsDeleted: false
    CreatedDate: 2015-06-18T22:02:05.000+0000
    CreatedById: 0051a000000K7Y7AAK
    LastModifiedDate: 2015-06-27T01:41:37.000+0000
    LastModifiedById: 0051a000000K7Y7AAK
    SystemModstamp: 2015-06-27T01:41:37.000+0000
    UserId: 0051a000000K7Y7AAK
    Name: Default
    Content:

    ID of IDEWorkspace is "1de1a0000014sEWAAY".
    4. login to Workbench and go to REST Explorer
    5. do GET for "/services/data/v29.0/tooling/sobjects/IDEWorkspace/1de1a0000014sEWAAY" You will see the content of IDEWorkspace 6. do DELETE
    7. re-open Developer Console
    You will see an error. And you will see that menus are available.
    8. Create a new workspace as the old workspace as been deleted Then, Developer Console will work fine.

    how do i execute the query from dev console in chrome? Use the following query to get the IDEWorkspace /services/data/v31.0/tooling/query/?q=SELECT id, name from IDEWorkspace

    @textual After pressing F12, you get the developer tools and on refresh of the developer console, you receive the logs in the same window. This is a query in logs and can be seen if you put a filter on IDEWorkspace. query would be something like - GET /services/data/v38.0/tooling/query/?q=SELECT%20Id,%20Name,%20Content%20FROM%20IDEWorkspace%20WHERE%20(Id=%271df280000004E9KAAU%27)%20OR%20 Pull out the Workspace ID from it

    If you do not mind about loosing all of yours (or someone else's) console workspaces, this can be simpler - just run a query via workbench and then delete everything you find.

    I have created an APEX script that does that for you. https://github.com/pranayjswl007/DevConsoleEnablerApex

    Just had this issue, and the chosen answer was really helpful. However, if you have access to a different user, there is an easier way. Log into the other user's dev console. Query with the tooling API: `SELECT Id, Name, CreatedBy.Name FROM IdeWorkspace` Delete the rows for the affected user only.

    For anyone struggling with Developer Tools, I found a similar solution and walkthrough at Developer Console Inoperable Menus that only requires the Salesforce Workbench.

    Using the idea of deleting the workspace along with @Wookie88 suggestion, I was able to copy the url into a new tab, then create a New Workspace under the Workspace menu and delete the old workspace in Workspace Manger.

    I am using the "Salesforce Inspector" browser extension to do export with the following SOQL: SELECT Id FROM IDEWorkspace and then deleting the result with the import option

    @Nic how do I get past the 'INVALID_TYPE: sObject type 'IDEWorkspace' is not supported.' part when I perform the SOQL?

    Nvm I found out to get past the 'INVALID_TYPE: sObject type 'IDEWorkspace' is not supported.' I needed to enable Tooling API

    wow this is such garbage that we have to do this. I used the Salesforce Inspector Chrome extension for the query and the deletion, since we've used it for similar past workflows, and it worked just fine. Thanks for the tip.

    I did face this issue, and based on this answer I could get some insights but not involved Google Dev Tools, maybe by the evolution of Salesforce platform or API.

    For me what did work was going to Workbench, Rest Explorer, did make a GET request for "/services/data/v51.0/tooling/query/?q=SELECT id, name from IDEWorkspace", here did use use API version 51. Then I get the ID of IDEWorkspace sObject from the response and use to make another GET request, just for check it this object, "/services/data/v51.0/tooling/sobjects/IDEWorkspace/{ID}", substitute the placeholder for your IDEWorkspace ID. Then, just changed the verb HTTP, for DELETE, and make a request, so the register was deleted it and login again in the console IDE without "Loading..." issue.

License under CC-BY-SA with attribution


Content dated before 7/24/2021 11:53 AM